Resolved
Pyth Pro experienced a service degradation due to network issues at one of our infrastructure providers. The affected period was 14:10:39 - 14:11:09 UTC and during this time users may have seen delayed price updates on some feeds
Investigating
Pyth Pro is experiencing a service degradation due to network issues at one of our infrastructure providers. Users may experience delayed price updates on some feeds.