Resolved
Pyth Pro historical database is now operating as expected again. These issues stemmed from underlying Clickhouse issues. All missed data has already been backfilled.
Investigating
Pyth Pro historical database is currently facing issues coming from Clickhouse cloud issues. Some historical data is not being successfully stored in the public historical database accessible via API.